projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
299bdf6
)
poppler: link with libatomic when needed
author
Waldemar Brodkorb
<wbx@openadk.org>
Mon, 28 May 2018 18:19:53 +0000
(20:19 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Mon, 28 May 2018 18:23:18 +0000
(20:23 +0200)
Following errors might occur on architectures required to use gcc libatomics:
sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line
This is often the case for sparcv8 32 bit toolchains.
See
55a9d6d55888b04ec6c476399e5b98a2412995f5
and
03f6e005e6a9617767b24a9026da9477848020cc
.
Fixes:
http://autobuild.buildroot.net/results/
64a96663a48ab644bc03c9a3ec2d6a644119dee6
http://autobuild.buildroot.net/results/
82e85e12478fc1972b70ad728ed7c1554920c9e3
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/poppler/poppler.mk
patch
|
blob
|
history
diff --git
a/package/poppler/poppler.mk
b/package/poppler/poppler.mk
index 5946cbec2479ac2783fb873d0a63d9b1eb3c3e52..bad61a6613362034510a8895fd9aa1e86186ef78 100644
(file)
--- a/
package/poppler/poppler.mk
+++ b/
package/poppler/poppler.mk
@@
-14,6
+14,10
@@
POPPLER_INSTALL_STAGING = YES
POPPLER_CONF_OPTS = --with-font-configuration=fontconfig \
--enable-xpdf-headers
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+POPPLER_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -latomic"
+endif
+
ifeq ($(BR2_PACKAGE_CAIRO),y)
POPPLER_CONF_OPTS += --enable-cairo-output
POPPLER_DEPENDENCIES += cairo