Revert "util-linux: add nsenter option"
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 21:40:18 +0000 (22:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 21:44:05 +0000 (22:44 +0100)
This reverts commit 9f91d79601da42516752318beecfd080dc05aac9.

Not all toolchains have setns(), and the configure script automatically
enables nsenter if it does, so get rid of the explicit option.

See http://lists.busybox.net/pipermail/buildroot/2014-February/088669.html
for details.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/util-linux/Config.in
package/util-linux/util-linux.mk

index ed19f3916069fe14dc1a824c75444a02f98223a8..8c8fd7ab5c66049a42a83f2c2f4e68a9fa8632ab 100644 (file)
@@ -106,11 +106,6 @@ config BR2_PACKAGE_UTIL_LINUX_MOUNT
        help
          Mount/unmount filesystems
 
-config BR2_PACKAGE_UTIL_LINUX_NSENTER
-       bool "nsenter"
-       help
-         Enter namespaces (setns(2) frontend)
-
 config BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT
        bool "pivot_root"
        help
index 5e689f8646de8b0784c7046998a828698bd1e02a..20b3d3558a31421440a05c8afc9a6af3bf1c5a8c 100644 (file)
@@ -62,7 +62,6 @@ UTIL_LINUX_CONF_OPT += \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),--enable-last --enable-login --enable-su --enable-sulogin,--disable-last --disable-login --disable-su --disable-sulogin) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MESG),--enable-mesg,--disable-mesg) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MOUNT),--enable-mount,--disable-mount) \
-       $(if $(BR2_PACKAGE_UTIL_LINUX_NSENTER),--enable-nsenter,--disable-nsenter) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_PARTX),,--disable-partx) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT),--enable-pivot_root,--disable-pivot_root) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_RAW),--enable-raw,--disable-raw) \