target/common: do not use IMAGE
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Mar 2010 21:11:21 +0000 (22:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:35 +0000 (11:04 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/common.mk

index c7eff7435ae88dbda6954aef246e260766e7b86b..cebe8c34a88569aaff498a7fc70d35617da1beaa 100644 (file)
@@ -31,8 +31,8 @@ FAKEROOT_SCRIPT = $(BUILD_DIR)/_fakeroot.fs
 
 define ROOTFS_TARGET_INTERNAL
 
-$(IMAGE).$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
-       @$(call MESSAGE,"Generating root filesystem image $(IMAGE).$(1)")
+$(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
+       @$(call MESSAGE,"Generating root filesystem image rootfs.$(1)")
        $(foreach hook,$(ROOTFS_$(2)_PRE_GEN_HOOKS),$(call $(hook))$(sep))
        rm -f $(FAKEROOT_SCRIPT)
        touch $(BUILD_DIR)/.fakeroot.00000
@@ -56,7 +56,7 @@ ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZMA),y)
        $(LZMA) -9 -c $$@ > $$@.lzma
 endif
 
-$(1)-root: $(IMAGE).$(1)
+$(1)-root: $(BINARIES_DIR)/rootfs.$(1)
 
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
 TARGETS += $(1)-root
@@ -65,4 +65,4 @@ endef
 
 define ROOTFS_TARGET
 $(call ROOTFS_TARGET_INTERNAL,$(1),$(call UPPERCASE,$(1)))
-endef
\ No newline at end of file
+endef