autoconf: don't try to build Emacs files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Mar 2013 23:18:22 +0000 (23:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 9 Mar 2013 11:07:35 +0000 (12:07 +0100)
When building autoconf for the target, we already passed EMACS="no" to
prevent autoconf from building Emacs mode files. But we weren't doing
that when building autoconf for the host. This causes problems when
'emacs' is not really emacs, but a sort of clone like Jove. So we also
pass EMACS="no" when building host-autoconf to avoid autoconf
./configure script from detecting emacs and then use it to build .elc
files from .el source code.

Reported-by: Spielmann Werner <Werner.Spielmann@swarovski.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/autoconf/autoconf.mk

index 0c36b66fce36239965ef9def58486aaee8c165bf..daac1f2179181dfce4e400d39e02341991baff9e 100644 (file)
@@ -15,7 +15,7 @@ AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
 
 AUTOCONF_DEPENDENCIES = host-m4 perl
 
-HOST_AUTOCONF_CONF_ENV = ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
+HOST_AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
                        ac_cv_prog_gnu_m4_gnu=no
 
 HOST_AUTOCONF_DEPENDENCIES = host-m4 host-libtool