Makefile.autotools.in: fix BR2_PRIMARY_SITE check
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 26 Jun 2008 11:43:02 +0000 (11:43 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 26 Jun 2008 11:43:02 +0000 (11:43 -0000)
Empty strings gets defined to "", so check for that instead of if
the variable is defined.

package/Makefile.autotools.in

index e4397c337f6c3dee622ca4c4248de8495b8d8701..76d734745ba8204af67714006dc394d5277ebd0f 100644 (file)
@@ -135,7 +135,8 @@ ifneq ($(filter source,$(MAKECMDGOALS)),)
        $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
 else
        $(call MESSAGE,"Downloading")
-ifdef BR2_PRIMARY_SITE
+ifneq ($(strip $(subst ",,$(BR2_PRIMARY_SITE))),)
+#"))
        -$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $(BR2_PRIMARY_SITE)/$($(PKG)_SOURCE)
 endif
        $(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)