update
authorEric Andersen <andersen@codepoet.org>
Wed, 10 Aug 2005 12:50:47 +0000 (12:50 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 10 Aug 2005 12:50:47 +0000 (12:50 -0000)
package/ltp-testsuite/ltp-testsuite.mk
package/ltp-testsuite/ltp-testsuite.patch

index 0d4082de295e9bc7ef02d8419dbdd0aef1014277..5c05613ef8260ee477784e69eaae9d62d68d2a7e 100644 (file)
@@ -3,11 +3,12 @@
 # ltp-testsuite
 #
 #############################################################
-LTP_TESTSUITE_SOURCE:=ltp-full-20050707.tgz
+LTP_TESTSUITE_VERSION:=20050804
+LTP_TESTSUITE_SOURCE:=ltp-full-$(LTP_TESTSUITE_VERSION).tgz
 LTP_TESTSUITE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ltp
 LTP_TESTSUITE_CAT:=zcat
 LTP_TESTSUITE_ROOT:=$(TARGET_DIR)/root
-LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-20050707
+LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-$(LTP_TESTSUITE_VERSION)
 
 
 $(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
index 3251d7ce6c5a168eb4cfc447be2cc7f1fb7d8c98..69e27d7f3b0222bfd42d755c30241dc109533689 100644 (file)
@@ -1,52 +1,3 @@
-diff -urN ltp-full-20050707-dist/lib/tlibio.c ltp-full-20050707/lib/tlibio.c
---- ltp-full-20050707-dist/lib/tlibio.c        2005-07-11 16:28:09.000000000 -0600
-+++ ltp-full-20050707/lib/tlibio.c     2005-08-02 19:56:11.000000000 -0600
-@@ -101,9 +101,11 @@
- #endif
- #if defined(linux) || defined(__sun) || defined(__hpux) || defined(_AIX)
- #ifndef UCLINUX
-+#ifndef __UCLIBC__
- #include <aio.h>
- #endif
- #endif
-+#endif
- #include <stdlib.h> /* atoi, abs */
- #include "tlibio.h"           /* defines LIO* marcos */
-diff -urN ltp-full-20050707-dist/testcases/kernel/io/disktest/Makefile ltp-full-20050707/testcases/kernel/io/disktest/Makefile
---- ltp-full-20050707-dist/testcases/kernel/io/disktest/Makefile       2005-05-04 11:54:00.000000000 -0600
-+++ ltp-full-20050707/testcases/kernel/io/disktest/Makefile    2005-08-02 21:13:22.000000000 -0600
-@@ -150,8 +150,8 @@
- VER=`grep VER_STR main.h | awk -F\" '{print $$2}'`
- GBLHDRS=main.h globals.h defs.h
--ALLHDRS=$(wildcard *.h)
--SRCS=$(wildcard *.c)
-+ALLHDRS=#$(wildcard *.h)
-+SRCS=#$(wildcard *.c)
- OBJS=$(SRCS:.c=.o)
- CFLAGS= -g -Wall -O -D"LINUX" -D"_THREAD_SAFE" -D"_GNU_SOURCE" -D"_LARGE_FILES" -D"_LARGEFILE64_SOURCE" -D"_FILE_OFFSET_BITS=64"
-@@ -159,7 +159,7 @@
- all: $(OBJS) disktest
- disktest: $(OBJS) $(SRCS) $(ALLHDRS)
--      $(CC) $(CFLAGS) -lpthread -odisktest $(OBJS)
-+      echo NEED TO $(CC) $(CFLAGS) -lpthread -odisktest $(OBJS)
- main.o: main.c $(ALLHDRS)
- sfunc.o: sfunc.c sfunc.h $(GBLHDRS)
-@@ -175,8 +175,8 @@
- stats.o: stats.c stats.h $(GBLHDRS)
- install: disktest
--      cp disktest $(bindir)
--      cp man1/disktest.1.gz $(mandir)/man1
-+      echo NEED TO cp disktest $(bindir)
-+      echo NEED TO cp man1/disktest.1.gz $(mandir)/man1
- uninstall: disktest
-       rm -f $(bindir)/disktest
 diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20050707/testcases/kernel/syscalls/fmtmsg/Makefile
 --- ltp-full-20050707-dist/testcases/kernel/syscalls/fmtmsg/Makefile   2005-07-11 16:28:18.000000000 -0600
 +++ ltp-full-20050707/testcases/kernel/syscalls/fmtmsg/Makefile        2005-08-02 19:56:11.000000000 -0600