autotools: inherit LIBTOOL_PATCH for host packages
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 28 Apr 2010 21:40:45 +0000 (23:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 21:26:22 +0000 (23:26 +0200)
When FOO_LIBTOOL_PATCH is defined, assume that the same value should
be used for HOST_FOO_LIBTOOL_PATCH.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index fc5bcee343fde41003d9d0c08b77aa6489f273d8..bbc79b7c8ba6bd45295b817ec8cb8160966ecd80 100644 (file)
@@ -49,6 +49,14 @@ ifndef $(2)_SUBDIR
  endif
 endif
 
+ifndef $(2)_LIBTOOL_PATCH
+ ifdef $(3)_LIBTOOL_PATCH
+  $(2)_LIBTOOL_PATCH = $($(3)_LIBTOOL_PATCH)
+ else
+  $(2)_LIBTOOL_PATCH ?= YES
+ endif
+endif
+
 $(2)_CONF_ENV                  ?=
 $(2)_CONF_OPT                  ?=
 $(2)_MAKE                      ?= $(MAKE)
@@ -56,7 +64,6 @@ $(2)_MAKE_ENV                 ?=
 $(2)_MAKE_OPT                  ?=
 $(2)_AUTORECONF                        ?= NO
 $(2)_AUTORECONF_OPT            ?=
-$(2)_LIBTOOL_PATCH             ?= YES
 $(2)_USE_CONFIG_CACHE           ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
 ifeq ($(BR2_ENABLE_DEBUG),y)