webkit: silence gazillions of warnings
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 Dec 2012 07:29:41 +0000 (07:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Dec 2012 18:07:33 +0000 (19:07 +0100)
Building webkit with a recent gcc versions gives gazillions of
warnings such as 'warning: cast from 'WTF::AlignedBufferChar* {aka
char*}' to 'JSC::Identifier*' increases required alignment of target
type [-Wcast-align]'.

Those make the webkit build very noise, and hard to debug, so let's
silence those warnings.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/webkit/webkit.mk

index 580c5d254f2eb590a91f4f5e5a99bfa968144181..326be146dc808741fc54a35f9d0a0701b64d494a 100644 (file)
@@ -9,7 +9,13 @@ WEBKIT_SITE = http://www.webkitgtk.org
 WEBKIT_INSTALL_STAGING = YES
 WEBKIT_DEPENDENCIES = host-flex host-gperf icu libcurl libxml2 libxslt \
                        libgtk2 sqlite enchant libsoup jpeg libgail
-WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config
+
+# Give explicit path to icu-config, and silence gazillions of warnings
+# with recent gcc versions.
+WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
+       CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align" \
+       CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align"
+
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
        WEBKIT_CONF_OPT += --with-target=x11