libeXosip: add dependency on host-pkg-config and remove useless flags
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 08:03:32 +0000 (10:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 14:04:38 +0000 (16:04 +0200)
When libeXosip fails to use pkg-config to find libosip, it defaults to
thinking that libosip is installed in $(prefix)/lib and
$(prefix)/include, which is of course wrong. There was an attempt to
fix this by passing OSIP_CFLAGS and OSIP_LIBS variables to libeXosip
./configure script, but it still does not work:

checking pkg-config is at least version 0.9.0... ./configure: line 21035: /home/test/outputs/test-41/host/usr/bin/pkg-config: No such file or directory
no
checking for OSIP... configure: WARNING: assuming osip can be found in -I${prefix}/include and -L${exec_prefix}/lib

Therefore, the correct fix is to depend on host-pkg-config.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libeXosip2/libeXosip2.mk

index 7f282b748df652c3a3cf7c50827f6e79a897c6c7..30eac9f067ffa4c1cd132bed3d3110b17beaa5e7 100644 (file)
@@ -22,8 +22,6 @@ $(LIBEXOSIP2_DIR)/.configured: $(LIBEXOSIP2_DIR)/.unpacked
        (cd $(LIBEXOSIP2_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_ARGS) \
-               OSIP_CFLAGS="$(TARGET_CFLAGS)" \
-               OSIP_LIBS="-L$(STAGING_DIR)/usr/lib -losip2 -losipparser2" \
                ./configure $(QUIET) \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -73,7 +71,7 @@ $(TARGET_DIR)/usr/bin/sip_reg: $(STAGING_DIR)/usr/bin/sip_reg
 
 
 
-libeXosip2: libosip2 $(TARGET_DIR)/usr/lib/libeXosip2.so
+libeXosip2: host-pkg-config libosip2 $(TARGET_DIR)/usr/lib/libeXosip2.so
 
 libeXosip2-source: $(DL_DIR)/$(LIBEXOSIP2_SOURCE)