sqlite: refactor how CFLAGS are passed to the configure script
authorSven Neumann <s.neumann@raumfeld.com>
Wed, 7 Dec 2011 19:00:09 +0000 (20:00 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Dec 2011 21:16:16 +0000 (22:16 +0100)
Change the way the SQLITE_CONF_ENV variable is constructed in
preparation of passing other CFLAGS to the configure script.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sqlite/sqlite.mk

index f587f47705f2ed4a977f7e1e639841040480f1db..0bee337e77ecb0053f00b0a2367b868ac09a73cd 100644 (file)
@@ -13,9 +13,11 @@ ifneq ($(BR2_LARGEFILE),y)
 # the sqlite configure script fails to define SQLITE_DISABLE_LFS when
 # --disable-largefile is passed, breaking the build. Work around it by
 # simply adding it to CFLAGS for configure instead
-SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
+SQLITE_CFLAGS += -DSQLITE_DISABLE_LFS
 endif
 
+SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
+
 SQLITE_CONF_OPT = \
        --enable-threadsafe \
        --localstatedir=/var