squid: fix old distro gcc build failure
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 27 Jan 2015 20:30:54 +0000 (17:30 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 27 Jan 2015 22:10:43 +0000 (23:10 +0100)
Squid 3.5.x deprecated the use of HOSTCXX & friends in favour of
BUILDCXX and BUILDCXXFLAGS.
When they are not specified BUILDCXXFLAGS takes flags from target
CXXFLAGS which specifies C11 standard and which older vesions of gcc
don't understand, thus causing breakage.
cf_gen hasn't got any C11 features so it's not required. Fixes:
http://autobuild.buildroot.net/results/816/8162e4ec941e7642248373be47cca99113a648e8/

Also drop ACLOCAL and AUTOMAKE trickery from e27ccbab since it's no
longer required.

And fix a typo in the hash file pointing to an improper hash file
upstream.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/squid/squid.hash
package/squid/squid.mk

index a067383a1d264d23dadde14f3fb3e6e0c104eb54..574d4620e1cad9e163f20b3e7afa1240c259e926 100644 (file)
@@ -1,3 +1,3 @@
-# From http://www.squid-cache.org/Versions/v3/3.4/squid-3.5.1.tar.xz.asc
+# From http://www.squid-cache.org/Versions/v3/3.5/squid-3.5.1.tar.xz.asc
 md5    b3c9d9726314c1136b7a4c06447db24b        squid-3.5.1.tar.xz
 sha1   a2b01afd33d1df3a234e1a5c3405d626f6cf0fb0        squid-3.5.1.tar.xz
index deb9360c067864a6d12cb4b23c2f7587eff8e55b..e385c375c74341a4d0c1b44d278a414c75850e35 100644 (file)
@@ -21,8 +21,8 @@ SQUID_CONF_ENV = \
        ac_cv_func___va_copy=yes \
        ac_cv_func_strnstr=no \
        ac_cv_have_squid=yes \
-       ACLOCAL="$(ACLOCAL)" \
-       AUTOMAKE="$(AUTOMAKE)"
+       BUILXCXX="$(HOSTCXX)" \
+       BUILDCXXFLAGS="$(HOST_CXXFLAGS)"
 SQUID_CONF_OPTS = \
        --enable-async-io=8 \
        --enable-linux-netfilter \