Revert "linux: fix check of configuration file existence"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:30 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:30 +0000 (19:16 +0100)
This reverts commit 477c28cf1d637b224b819dd278103a05fb6f9dbb. The
whole host-lzop optional dependency logic cannot work, since the
configuration file will only be known after the kernel sources are
extracted, if an internal kernel defconfig is used, which is quite
common.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 91a5fb8d814229bc2a08103edc2e27cb2e75c756..ec7dfc39ec6fd65d5202d675b0a28fe7f6bcbead 100644 (file)
@@ -166,11 +166,9 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
 KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
 endif
 
-ifeq ($(BR2_LINUX_KERNEL),y)
 ifeq ($(wildcard $(KERNEL_SOURCE_CONFIG)),)
 $(error Configuration file '$(KERNEL_SOURCE_CONFIG)' not found.)
 endif
-endif
 
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_KERNEL_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop