sdl_sound: needs iconv if !locale
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Jul 2010 06:54:47 +0000 (08:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Jul 2010 06:54:47 +0000 (08:54 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl_sound/Config.in
package/sdl_sound/sdl_sound.mk

index 08ad7542cdc9fe50f6b760d54ba98f37fbce9cde..542c996b2991d1983ba6da5095defd67252cdec2 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_SDL_SOUND
        bool "SDL_sound"
        depends on BR2_PACKAGE_SDL
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          SDL_sound is a library that handles the decoding of several
          popular sound file formats, such as .WAV and .MP3.
index 610e9681a63b62ee94ed94105a3b0274eef72dc4..5058551b017dcf6925228825ef88fc3bfc949ea2 100644 (file)
@@ -11,6 +11,10 @@ SDL_SOUND_INSTALL_STAGING:=YES
 SDL_SOUND_INSTALL_TARGET:=YES
 SDL_SOUND_DEPENDENCIES = sdl
 
+ifneq ($(BR2_ENABLE_LOCALE),y)
+SDL_SOUND_DEPENDENCIES += libiconv
+endif
+
 SDL_SOUND_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
                --disable-sdltest \