gcc: remove gcc snapshot option
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 10:09:34 +0000 (12:09 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 10:09:34 +0000 (12:09 +0200)
As discussed during the dev days. It is broken for uClibc/musl and
architectures not using mainline gcc, so it has only very limited
usefulness.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/Config.in.host
package/gcc/gcc.mk

index 75c589c967120d5b65f726946f0bdd9f072f89d3..d96428cf3aa5d6a3069638a474628440d3967db1 100644 (file)
@@ -112,34 +112,12 @@ choice
                select BR2_GCC_NEEDS_MPC
                select BR2_GCC_SUPPORTS_GRAPHITE
 
-       config BR2_GCC_VERSION_SNAP
-               bool "gcc snapshot"
-               # Broken or unsupported architectures
-               depends on !BR2_arc && !BR2_avr32
-               # musl patches only for release gcc versions
-               depends on !BR2_TOOLCHAIN_BUILDROOT_MUSL
-               select BR2_GCC_NEEDS_MPC
-               select BR2_GCC_SUPPORTS_GRAPHITE
 endchoice
 
 config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
        bool
        default y if !BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
 
-config BR2_GCC_SNAP_DATE
-       string "GCC snapshot date"
-       default "4.8-20120429"
-       depends on BR2_GCC_VERSION_SNAP
-       help
-         Enter snapshot date to use for gcc.
-         Format is: A.B-YYYYMMDD
-
-         A is GCC major version, for example 4.
-         B is GCC minor version, for example 7.
-         YYYYMMDD is snapshot date, for example 20110430.
-
-         This way we'd get version 4.7-20110430
-
 config BR2_GCC_VERSION
        string
        default "4.2.2-avr32-2.1.5" if BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
@@ -149,7 +127,6 @@ config BR2_GCC_VERSION
        default "4.8.3"     if BR2_GCC_VERSION_4_8_X
        default "4.9.1"     if BR2_GCC_VERSION_4_9_X
        default "arc-2014.08" if BR2_GCC_VERSION_4_8_ARC
-       default BR2_GCC_SNAP_DATE if BR2_GCC_VERSION_SNAP
 
 config BR2_EXTRA_GCC_CONFIG_OPTIONS
        string "Additional gcc options"
index 3303591c080f1c43164d1dfd11c8869b6d9edf71..7bed159c04b84257b8305da9eed2a00f2d625f45 100644 (file)
 
 GCC_VERSION = $(call qstrip,$(BR2_GCC_VERSION))
 
-ifeq ($(BR2_GCC_VERSION_SNAP),y)
-GCC_SNAP_DATE = $(call qstrip,$(BR2_GCC_SNAP_DATE))
-endif
-
-ifneq ($(GCC_SNAP_DATE),)
-GCC_SITE = ftp://gcc.gnu.org/pub/gcc/snapshots/$(GCC_SNAP_DATE)
-else ifeq ($(findstring avr32,$(GCC_VERSION)),avr32)
+ifeq ($(findstring avr32,$(GCC_VERSION)),avr32)
 GCC_SITE = ftp://www.at91.com/pub/buildroot
 else ifeq ($(BR2_arc),y)
 GCC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gcc,$(GCC_VERSION))
@@ -160,7 +154,7 @@ else
 HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
 endif
 
-ifneq ($(BR2_arc)$(BR2_GCC_VERSION_SNAP),)
+ifeq ($(BR2_arc),y)
 HOST_GCC_COMMON_DEPENDENCIES += host-flex host-bison
 endif