target/generic: /etc/{hostname,issue}: work around quotes in kconfig
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Oct 2009 13:08:55 +0000 (15:08 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Oct 2009 13:08:55 +0000 (15:08 +0200)
Otherwise the targets will always run.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
target/generic/Makefile.in

index 31f4a0c3b7efae8210381e2de12a3491c3c46d2f..f77f9698c81b27536a5e3feb9a5681ec93cc1b6c 100644 (file)
@@ -7,6 +7,8 @@ TARGET_SKELETON=target/generic/target_busybox_skeleton
 TARGET_DEVICE_TABLE=target/generic/mini_device_table.txt
 endif
 
+TARGET_GENERIC_HOSTNAME:=$(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))
+TARGET_GENERIC_ISSUE:=$(call qstrip,$(BR2_TARGET_GENERIC_ISSUE))
 TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
 TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
 
@@ -22,11 +24,11 @@ target-generic-getty:
        $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
                $(TARGET_DIR)/etc/inittab
 
-ifneq ($(BR2_TARGET_GENERIC_HOSTNAME),)
+ifneq ($(TARGET_GENERIC_HOSTNAME),)
 TARGETS += target-generic-hostname
 endif
 
-ifneq ($(BR2_TARGET_GENERIC_ISSUE),)
+ifneq ($(TARGET_GENERIC_ISSUE),)
 TARGETS += target-generic-issue
 endif