opkg: Add gnupg signature checking support.
authorPhilipp Claves <claves@budelmann-elektronik.com>
Fri, 1 Mar 2013 13:38:29 +0000 (14:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 Jul 2013 11:49:53 +0000 (13:49 +0200)
[Thomas: add ac_cv_path_GPGME_CONFIG in the configure environment to
help opkg find libgpgme.]

Signed-off-by: Philipp Claves <claves@budelmann-elektronik.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/opkg/Config.in
package/opkg/opkg.mk

index eb997a7d4b15460e4881bb7f37062eb7d2197280..5906210e86609c1a8d3b41d0b5e1a49ca5ad0ab9 100644 (file)
@@ -11,3 +11,13 @@ config BR2_PACKAGE_OPKG
 
          http://code.google.com/p/opkg/
 
+if BR2_PACKAGE_OPKG
+
+config BR2_PACKAGE_OPKG_GPG_SIGN
+       bool "gnupg support"
+       select BR2_PACKAGE_LIBGPGME
+       help
+         Enable opkg package signature checking support using
+         gnupg/libgpgme.
+
+endif
index 9e1c623754b86a0d2c74aa6f2b7689a5a804bb8f..5846433caa649c43740b9a8851388d89121d0c6f 100644 (file)
@@ -9,7 +9,7 @@ OPKG_SOURCE = opkg-$(OPKG_VERSION).tar.gz
 OPKG_SITE = http://opkg.googlecode.com/svn/trunk/
 OPKG_SITE_METHOD = svn
 OPKG_INSTALL_STAGING = YES
-OPKG_CONF_OPT = --disable-curl --disable-gpg
+OPKG_CONF_OPT = --disable-curl
 OPKG_AUTORECONF = YES
 # Uses PKG_CHECK_MODULES() in configure.ac
 OPKG_DEPENDENCIES = host-pkgconf
@@ -19,6 +19,14 @@ define OPKG_CREATE_LOCKDIR
        mkdir -p $(TARGET_DIR)/usr/lib/opkg
 endef
 
+ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
+OPKG_CONF_OPT += --enable-gpg
+OPKG_CONF_ENV = ac_cv_path_GPGME_CONFIG=$(STAGING_DIR)/usr/bin/gpgme-config
+OPKG_DEPENDENCIES += libgpgme
+else
+OPKG_CONF_OPT += --disable-gpg
+endif
+
 OPKG_POST_INSTALL_TARGET_HOOKS += OPKG_CREATE_LOCKDIR
 
 $(eval $(autotools-package))