pcre: add options to enable UTF and UCP support
authorSven Neumann <neumann@teufel.de>
Fri, 22 Nov 2013 21:58:15 +0000 (22:58 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 25 Nov 2013 10:01:25 +0000 (11:01 +0100)
Allow to compile PCRE with UTF-8/16/32 support and with
support for Unicode properties.

[Peter: whitespace fix]
Signed-off-by: Sven Neumann <neumann@teufel.de>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pcre/Config.in
package/pcre/pcre.mk

index dc92274102c8181f297fb152b24bdd514654223a..9d3a143365a70c30f4dd94471e769be4123e1bae 100644 (file)
@@ -19,4 +19,16 @@ config BR2_PACKAGE_PCRE_32
        help
          This option builds the 32-bits pcre library, i.e 'libpcre32'
 
+config BR2_PACKAGE_PCRE_UTF
+       bool "UTF-8/16/32 support in pcre"
+       help
+         This option builds the pcre library with UTF-8/16/32 support
+
+config BR2_PACKAGE_PCRE_UCP
+       bool "Unicode properties support in pcre"
+       select BR2_PACKAGE_PCRE_UTF
+       help
+         This option builds the pcre library with Unicode properties
+         support (implies UTF-8/16/32 support)'
+
 endif
index bf86a3daacfa4e438acb56553f69dca055dbacbb..26373545e67dfd707667ec1eab20f68af51b2710 100644 (file)
@@ -19,5 +19,7 @@ endif
 PCRE_CONF_OPT += --enable-pcre8
 PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
 PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_UTF),--enable-utf,--disable-utf)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_UCP),--enable-unicode-properties,--disable-unicode-properties)
 
 $(eval $(autotools-package))