package: add xz-utils package
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Sep 2010 15:32:46 +0000 (17:32 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Sep 2010 15:45:31 +0000 (17:45 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/xz/Config.in [new file with mode: 0644]
package/xz/xz.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 7ae67d94685f251c75d3b0784215ff84ae373d36..1127f89e70a9ecf89b2bf79adb984e3da90a199f 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -15,6 +15,8 @@
        Download handling reworked and support for git/svn downloads
        added.
 
+       New packages: xz
+
        Updated/fixed packages: alsa-lib, at, avahi, berkeleydb, bind,
        bmon, bridge-utils, busybox, dbus, dmraid, docker, dropbear,
        e2fsprogs, expat, freetype, gawk, gvfs, haserl, hostapd,
index f9a040555048204baba67cac436b3ea2d409565b..ce6057b973eccfe7983712d81e515207665a0215 100644 (file)
@@ -13,6 +13,7 @@ source "package/gzip/Config.in"
 endif
 source "package/lzop/Config.in"
 source "package/lzma/Config.in"
+source "package/xz/Config.in"
 endmenu
 
 menu "Debugging, profiling and benchmark"
diff --git a/package/xz/Config.in b/package/xz/Config.in
new file mode 100644 (file)
index 0000000..50116f2
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_XZ
+       bool "xz-utils"
+       help
+         XZ is the successor to the Lempel-Ziv/Markov-chain Algorithm
+         compression format, which provides memory-hungry but powerful
+         compression (often better than bzip2) and fast, easy decompression.
+
+         This package provides the command line tools for working with XZ
+         compression, including xz, unxz, xzcat, xzgrep, and so on. They can
+         also handle the older LZMA format, and if invoked via appropriate
+         symlinks will emulate the behavior of the commands in the lzma
+         package.
+
+         http://tukaani.org/xz/
diff --git a/package/xz/xz.mk b/package/xz/xz.mk
new file mode 100644 (file)
index 0000000..7490f77
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# xz-utils
+#
+#############################################################
+XZ_VERSION = 4.999.9beta
+XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
+XZ_SITE = http://tukaani.org/xz/
+XZ_INSTALL_STAGING = YES
+XZ_LIBTOOL_PATCH = NO
+
+$(eval $(call AUTOTARGETS,package,xz))
+$(eval $(call AUTOTARGETS,package,xz,host))