tpm2-tss: do not enforce -fstack-protector-all
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Jan 2019 10:15:16 +0000 (11:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Jan 2019 13:24:25 +0000 (14:24 +0100)
Stack protection is now controlled buildroot wide with the BR2_SSP_*
options, so disable the explicit -fstack-protector-all so the SSP logic in
the toolchain wrapper is used instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-tss/tpm2-tss.mk

index f005e5d6b8d456c75391c1535042abcb039a9e95..e2e58a092dc368339492d2cd77e81ebd4dfd71ea 100644 (file)
@@ -12,8 +12,9 @@ TPM2_TSS_INSTALL_STAGING = YES
 TPM2_TSS_DEPENDENCIES = liburiparser openssl host-pkgconf
 TPM2_TSS_CONF_OPTS = --with-crypto=ossl --disable-doxygen-doc
 
-# configure.ac doesn't contain a link test, so it doesn't detect when
-# libssp is missing.
-TPM2_TSS_CONF_ENV = ax_cv_check_cflags___________Wall__Werror_______fstack_protector_all=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
+# -fstack-protector-all is used by default. Disable that so the
+# BR2_SSP_* options in the toolchain wrapper are used instead
+TPM2_TSS_CONF_ENV = \
+       ax_cv_check_cflags___________Wall__Werror_______fstack_protector_all=no
 
 $(eval $(autotools-package))