python-json-schema-validator: needs versiontools on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 12 Jul 2017 16:27:58 +0000 (18:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Jul 2017 08:54:39 +0000 (10:54 +0200)
python-json-schema-validator does not need versiontools on the target,
but only on the host, as it's listed in setup_requires in setup.py.

This was not noticed so far because host Python interpreter is started
with a PYTHONPATH that contains a directory with target Python
packages, so versiontools was found there. But as we are about to fix
PYTHONPATH to no longer include such a directory,
python-json-schema-validator would fail due to versiontools being
missed on the host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-json-schema-validator/Config.in
package/python-json-schema-validator/python-json-schema-validator.mk

index dbc532823bfa1fa7759fc29242e9c07807234c28..e50e8eefc6b1590852184caf338087a4af245693 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_PYTHON_JSON_SCHEMA_VALIDATOR
        bool "python-json-schema-validator"
-       select BR2_PACKAGE_PYTHON_VERSIONTOOLS
        help
          JSON Schema Validator
 
index 6accbd6aee8afb10524cf28ba27bdfa8c055953a..c0a335cbd7c77cdba8073fadcaf6945187632cd4 100644 (file)
@@ -9,6 +9,6 @@ PYTHON_JSON_SCHEMA_VALIDATOR_SOURCE = json-schema-validator-$(PYTHON_JSON_SCHEMA
 PYTHON_JSON_SCHEMA_VALIDATOR_SITE = https://pypi.python.org/packages/70/46/ba39cb7efad1898cfc89bf3588b8612f24d128f1c25b761994f524a59cef
 PYTHON_JSON_SCHEMA_VALIDATOR_LICENSE = LGPL-3.0
 PYTHON_JSON_SCHEMA_VALIDATOR_SETUP_TYPE = setuptools
-PYTHON_JSON_SCHEMA_VALIDATOR_DEPENDENCIES = python-versiontools
+PYTHON_JSON_SCHEMA_VALIDATOR_DEPENDENCIES = host-python-versiontools
 
 $(eval $(python-package))