A bit more wiggling to prevent asking about the target
authorEric Andersen <andersen@codepoet.org>
Wed, 5 Nov 2003 01:34:17 +0000 (01:34 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 5 Nov 2003 01:34:17 +0000 (01:34 -0000)
architecture when possible, since we already know the
correct answer.

make/uclibc.mk
sources/uClibc.config

index a547eaf2b4e327601402cbd04ed95590e897cd9e..c5c69c5d33846c7f5a5aa7ecafd0ceb8794c1afa 100644 (file)
@@ -44,7 +44,8 @@ ifeq ($(ENABLE_LOCALE),true)
 else
        cp $(SOURCE_DIR)/uClibc.config $(UCLIBC_DIR)/.config
 endif
-       perl -i -p -e 's,^TARGET_[a-z].*,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' $(UCLIBC_DIR)/.config
+       perl -i -p -e 's,^.*TARGET_$(UCLIBC_TARGET_ARCH).*,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' \
+               $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^TARGET_ARCH.*,TARGET_ARCH=\"$(UCLIBC_TARGET_ARCH)\",g' $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_DIR)\",g' \
                $(UCLIBC_DIR)/.config
index b87042da225f936a1a4388e75550fea24166b338..d38ca852c0b4944fd80ccb996f94c477f8aa8a62 100644 (file)
@@ -1,13 +1,26 @@
 #
 # Automatically generated make config: don't edit
 #
-TARGET_i386=y
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_h8300 is not set
+# TARGET_i386 is not set
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
 
 #
 # Target Architecture Features and Options
 #
 HAVE_ELF=y
-TARGET_ARCH="i386"
+TARGET_ARCH="none"
 UCLIBC_HAS_FLOATS=y
 # ARCH_HAS_NO_FPU is not set
 HAS_FPU=y