package/empty: Respect LDFLAGS, fix link order
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 10 Aug 2014 14:57:52 +0000 (16:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 16 Aug 2014 14:46:04 +0000 (16:46 +0200)
Fixes
http://autobuild.buildroot.net/results/50f/50fedb54cf005d1177d85c5a34fd10a1c354ba5b/
http://autobuild.buildroot.net/results/9fc/9fce0825772e99de3c6808b729641147385413aa/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/empty/empty-0001-respect-LDFLAGS.patch [new file with mode: 0644]

diff --git a/package/empty/empty-0001-respect-LDFLAGS.patch b/package/empty/empty-0001-respect-LDFLAGS.patch
new file mode 100644 (file)
index 0000000..b98af07
--- /dev/null
@@ -0,0 +1,22 @@
+downloaded from
+http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-misc/empty/files/empty-respect-LDFLAGS.patch?view=markup
+
+Reported on the Gentoo bug tracker
+https://bugs.gentoo.org/show_bug.cgi?id=429664
+
+and reported upstream
+https://sourceforge.net/tracker/?func=detail&aid=3554236&group_id=136798&atid=736886
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- empty-0.6.18b/Makefile
++++ empty-0.6.18b/Makefile
+@@ -16,7 +16,7 @@
+ PREFIX = /usr/local
+ all:
+-      ${CC} ${CFLAGS} -Wall ${LIBS} -o empty empty.c
++      ${CC} ${CFLAGS} ${LDFLAGS} empty.c ${LIBS} -o empty
+ FreeBSD:      all
+ NetBSD:               all