package/gstreamer1/gst1-plugins-good: add option to enable/disable jack plugin
authorAdam Duskett <Aduskett@gmail.com>
Thu, 9 May 2019 22:46:20 +0000 (18:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 19:06:49 +0000 (21:06 +0200)
Currently there is no explicit way to turn the jack plugin on or off.
Create a menu entry allowing users to disable or enable the plugin,
like we have for other features (for example the Pulseaudio plugin).

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-good/Config.in
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index 3af05ba6b486937ee223c725554f53c7c6464d9a..433084fd6bb363ddaa76784b7b16ca5af039b0ea 100644 (file)
@@ -345,6 +345,19 @@ config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_GDKPIXBUF
 comment "gdkpixbuf needs a toolchain w/ wchar, threads"
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
 
+config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_JACK
+       bool "jack"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_STATIC_LIBS
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       select BR2_PACKAGE_JACK2
+       help
+         JACK audio source/sink plugin
+
+comment "jack needs a toolchain w/ C++, dynamic library"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS
+
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_PULSE
        bool "pulseaudio"
        depends on BR2_TOOLCHAIN_HAS_THREADS # pulseaudio
index 462d5e1307e76608f17eb62c0e1576dc013aa86f..829d27a2da8bd81a325010c9b4fd1e84ce6b4425 100644 (file)
@@ -30,7 +30,7 @@ GST1_PLUGINS_GOOD_CONF_OPTS += \
 
 GST1_PLUGINS_GOOD_DEPENDENCIES = gstreamer1 gst1-plugins-base
 
-ifeq ($(BR2_PACKAGE_JACK2),y)
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_JACK),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += --enable-jack
 GST1_PLUGINS_GOOD_DEPENDENCIES += jack2
 else