package/libvips: bump version to 8.8.1
authorIlya Averyanov <averyanovin@gmail.com>
Fri, 9 Aug 2019 10:46:55 +0000 (13:46 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 14 Aug 2019 13:34:28 +0000 (15:34 +0200)
- Remove patch, as gtk-doc disabling now works correctly.
- The XML library in use is now expat, instead of libxml2

Signed-off-by: Ilya Averyanov <averyanovin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/0001-fix-no-gtk-doc.patch [deleted file]
package/libvips/Config.in
package/libvips/libvips.hash
package/libvips/libvips.mk

diff --git a/package/libvips/0001-fix-no-gtk-doc.patch b/package/libvips/0001-fix-no-gtk-doc.patch
deleted file mode 100644 (file)
index bfaf7c3..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From a3d47be3b6bed845af5e1aa87ca2da2b1e840cbb Mon Sep 17 00:00:00 2001
-From: Pieter De Gendt <pieter.degendt@basalte.be>
-Date: Thu, 29 Jan 2015 12:25:35 +0100
-Subject: [PATCH] Same patch as for systemd in commit
- http://git.buildroot.net/buildroot/commit/?id=7144f2f04b70553
-
-Fix deactivation of gtk-doc
-
-The tarball contains the Makefile for building documentation with gtk-doc,
-Unfortunately the AM_CONDITIONAL variable is not the correct one, which
-results in an error when running autoreconf.
-
-This patch fixes this issue.
-
-Signed-off-by: Pieter De Gendt <pieter.degendt@gmail.com>
----
- doc/reference/gtk-doc.make | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/doc/reference/gtk-doc.make b/doc/reference/gtk-doc.make
-index e791656..786803e 100644
---- a/doc/reference/gtk-doc.make
-+++ b/doc/reference/gtk-doc.make
-@@ -267,7 +267,7 @@ uninstall-local:
- #
- # Require gtk-doc when making dist
- #
--if HAVE_GTK_DOC
-+if ENABLE_GTK_DOC
- dist-check-gtkdoc: docs
- else
- dist-check-gtkdoc:
--- 
-2.2.2
-
index e16e5277c04a425bc25e6dbbd3637c2419a001cc..70d01f0e35173c7460d6f30e2a3004cd725e1994 100644 (file)
@@ -6,8 +6,8 @@ config BR2_PACKAGE_LIBVIPS
        # C++ support is required to build libvips
        # https://github.com/jcupitt/libvips/issues/231
        depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_EXPAT
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_LIBXML2
        help
          libvips is a 2D image processing library. Compared to
          similar libraries, libvips runs quickly and uses little
index 18c1ae80f9ab4fda03b85e7668cfdbc03c9f5808..54d838bb9bb8dd4fe54628b9c05709e5944daa20 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256  45961855e21c8d5f0983d05bb79a6f3c2427dc6eed8e3ac68c0f62759b8612c6  vips-7.42.2.tar.gz
+sha256  a0ee255a2a1ebfea5b2dff2a780824d7157a78c010d7ddd531279aacefbf2539  vips-8.8.1.tar.gz
index 72fcf6003ecd5ecaa39d93e8b7930b2c84938d07..269b0866c884b476a1402a1c237217e7aed4079d 100644 (file)
@@ -4,14 +4,11 @@
 #
 ################################################################################
 
-LIBVIPS_VERSION_MAJOR = 7.42
-LIBVIPS_VERSION = $(LIBVIPS_VERSION_MAJOR).2
+LIBVIPS_VERSION = 8.8.1
 LIBVIPS_SOURCE = vips-$(LIBVIPS_VERSION).tar.gz
-LIBVIPS_SITE = http://www.vips.ecs.soton.ac.uk/supported/$(LIBVIPS_VERSION_MAJOR)
+LIBVIPS_SITE = https://github.com/libvips/libvips/releases/download/v$(LIBVIPS_VERSION)
 LIBVIPS_LICENSE = LGPL-2.1+
 LIBVIPS_LICENSE_FILES = COPYING
-# We're patching gtk-doc.make, so need to autoreconf
-LIBVIPS_AUTORECONF = YES
 
 # Sparc64 compile fails, for all optimization levels except -O0. To
 # fix the problem, use -O0 with no optimization instead. Bug reported
@@ -41,8 +38,8 @@ LIBVIPS_CONF_OPTS = \
        --without-python
 LIBVIPS_INSTALL_STAGING = YES
 LIBVIPS_DEPENDENCIES = \
-       host-pkgconf libglib2 \
-       libxml2 $(TARGET_NLS_DEPENDENCIES)
+       host-pkgconf expat libglib2 \
+       $(TARGET_NLS_DEPENDENCIES)
 
 # --disable-cxx is broken upstream
 # https://github.com/jcupitt/libvips/issues/231