package/tor: add optional dependency to zstd
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 6 Jan 2020 05:39:49 +0000 (06:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 10 Jan 2020 22:16:46 +0000 (23:16 +0100)
Fixes:
http://autobuild.buildroot.net/results/454/454309539101c55a572c12c699cf3542dfb21637/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tor/tor.mk

index 1b493f6993f3e5210067770adfcaf62459aa0d24..2ecb41f0729ee0d7d33b36f761f5da6bd68a1f83 100644 (file)
@@ -37,6 +37,13 @@ else
 TOR_CONF_OPTS += --disable-lzma
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+TOR_CONF_OPTS += --enable-zstd
+TOR_DEPENDENCIES += host-pkgconf zstd
+else
+TOR_CONF_OPTS += --disable-zstd
+endif
+
 ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
 TOR_CONF_OPTS += --enable-seccomp
 TOR_DEPENDENCIES += libseccomp