avahi: run as avahi user/group instead of default
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Jun 2014 22:00:16 +0000 (00:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Jun 2014 22:00:16 +0000 (00:00 +0200)
Create an avahi specific user/group and use it instead of the global
'default' one, so it can be removed.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/avahi/avahi.mk

index 6e84564b2d4ab6c1cfe4f92c6dd28c6fbac0a0bb..725e96bc0bf703c3d630bc42779587f499545ae9 100644 (file)
@@ -80,10 +80,10 @@ AVAHI_CONF_OPT = --localstatedir=/var \
                --with-distro=none \
                --disable-manpages \
                $(if $(BR2_PACKAGE_AVAHI_AUTOIPD),--enable,--disable)-autoipd \
-               --with-avahi-user=default \
-               --with-avahi-group=default \
-               --with-autoipd-user=default \
-               --with-autoipd-group=default
+               --with-avahi-user=avahi \
+               --with-avahi-group=avahi \
+               --with-autoipd-user=avahi \
+               --with-autoipd-group=avahi
 
 AVAHI_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-intltool \
        host-pkgconf host-gettext
@@ -136,6 +136,10 @@ endif
 
 AVAHI_MAKE_OPT += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),LIBS=-lintl)
 
+define AVAHI_USERS
+       avahi -1 avahi -1 * - - -
+endef
+
 define AVAHI_REMOVE_INITSCRIPT
        rm -rf $(TARGET_DIR)/etc/init.d/avahi-*
 endef