qt: only build gui module if enabled
authorFrederik Pasch <fpasch@googlemail.com>
Wed, 8 Dec 2010 22:09:03 +0000 (23:09 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 8 Dec 2010 22:09:24 +0000 (23:09 +0100)
Closes #2905

Signed-off-by: Frederik Pasch <fpasch@googlemail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/qt/qt.mk

diff --git a/CHANGES b/CHANGES
index f08353d0152481b885f1a1e52591d9fa359c9a7a..45585c18216c46673dfb46e29bf6f7ead0de9d60 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,10 +3,14 @@
        Ccache support reworked. Now used for both host and target
        compilation, and cache is stored in ~/.buildroot-ccache.
 
-       Updated/fixed packages: cloop, m4, openssh, xz
+       Updated/fixed packages: cloop, m4, openssh, qt, xz
 
        New packages: lsuio
 
+       Issues resolved (http://bugs.uclibc.org):
+
+       #2905: Qt: Speed up compilation, if gui-module isn't selected
+
 2010.11, Released November 30th, 2010:
 
        Fixes all over the tree.
index e344259aeed21ca0eaaa2d8f617228af2c90f73a..2b5b31b788b394d7cd8e996497b4fd9c7a618fd6 100644 (file)
@@ -190,6 +190,10 @@ else
 QT_CONFIGURE+= -big-endian
 endif
 
+ifneq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
+QT_CONFIGURE+= -no-gui
+endif
+
 ifeq ($(BR2_PACKAGE_QT_GIF),y)
 QT_CONFIGURE+= -qt-gif
 else