core/pkg-generic: only save latest package list
authorJohn Keeping <john@metanate.com>
Tue, 1 May 2018 12:28:41 +0000 (13:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 1 May 2018 13:21:56 +0000 (15:21 +0200)
When rebuilding a package, simply appending the package's file list to
the global list means that the package list grows for every rebuild, as
does the time taken to check for files installed by multiple packages.
Furthermore, we get false positives where a file is reported as being
installed by multiple copies of the same package.

With this approach we may end up with orphaned files in the target
filesystem if a package that has been updated and rebuilt no longer
installs the same set of files, but we know that only a clean build will
produce reliable results.  In fact it may be helpful to identify these
orphaned files as evidence that the build is not clean.

Signed-off-by: John Keeping <john@metanate.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-generic.mk

index bd47ca1964cc0487dfb4d64b18b4ef139036384e..87c856407d0838567b685579457dd44b3e04608d 100644 (file)
@@ -63,6 +63,8 @@ GLOBAL_INSTRUMENTATION_HOOKS += step_time
 # $(2): base directory to search in
 # $(3): suffix of file  (optional)
 define step_pkg_size_inner
+       @touch $(BUILD_DIR)/packages-file-list$(3).txt
+       $(SED) '/^$(1),/d' $(BUILD_DIR)/packages-file-list$(3).txt
        cd $(2); \
        find . \( -type f -o -type l \) \
                -newer $($(PKG)_DIR)/.stamp_built \