package/lua-lunix: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 13 Jun 2021 15:42:53 +0000 (17:42 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 13 Jul 2021 20:19:07 +0000 (22:19 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/lua-lunix/0001-fix-with-uClibc.patch [new file with mode: 0644]
package/lua-lunix/Config.in [new file with mode: 0644]
package/lua-lunix/lua-lunix.hash [new file with mode: 0644]
package/lua-lunix/lua-lunix.mk [new file with mode: 0644]
support/testing/tests/package/test_lua_lunix.py [new file with mode: 0644]

index 22947edf2c391c785096bcfccac47541f53cbcb1..e883cf3780d3f4252e96c34d9ce26b78897b8944 100644 (file)
@@ -679,6 +679,7 @@ menu "Lua libraries/modules"
        source "package/lua-livr-extra/Config.in"
        source "package/lua-lpeg-patterns/Config.in"
        source "package/lua-lunitx/Config.in"
+       source "package/lua-lunix/Config.in"
        source "package/lua-lyaml/Config.in"
        source "package/lua-markdown/Config.in"
        source "package/lua-messagepack/Config.in"
diff --git a/package/lua-lunix/0001-fix-with-uClibc.patch b/package/lua-lunix/0001-fix-with-uClibc.patch
new file mode 100644 (file)
index 0000000..236eec4
--- /dev/null
@@ -0,0 +1,28 @@
+From ee41d97a80b978f54941ac6857c00b8a8f28de24 Mon Sep 17 00:00:00 2001
+From: Francois Perrad <francois.perrad@gadz.org>
+Date: Sun, 6 Jun 2021 17:55:06 +0200
+Subject: [PATCH] fix with uClibc
+
+uClibc doesn't have is no sys_siglist.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+---
+ lunix-rel-20170920/src/unix.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lunix-rel-20170920/src/unix.c b/lunix-rel-20170920/src/unix.c
+index 5f3a70a..e561ab2 100644
+--- a/lunix-rel-20170920/src/unix.c
++++ b/lunix-rel-20170920/src/unix.c
+@@ -438,7 +438,7 @@
+ #endif
+ #ifndef HAVE_SYS_SIGLIST
+-#define HAVE_SYS_SIGLIST (!MUSL_MAYBE && !__sun && !_AIX)
++#define HAVE_SYS_SIGLIST (!MUSL_MAYBE && !__sun && !_AIX && !__UCLIBC__)
+ #endif
+ #ifndef HAVE_UNLINKAT
+-- 
+2.30.2
+
diff --git a/package/lua-lunix/Config.in b/package/lua-lunix/Config.in
new file mode 100644 (file)
index 0000000..ca9325a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LUA_LUNIX
+       bool "lua-lunix"
+       help
+         lunix is a bindings library module to common Unix system APIs.
+
+         http://25thandclement.com/~william/projects/lunix.html
diff --git a/package/lua-lunix/lua-lunix.hash b/package/lua-lunix/lua-lunix.hash
new file mode 100644 (file)
index 0000000..3cbf348
--- /dev/null
@@ -0,0 +1,3 @@
+# computed by luarocks/buildroot
+sha256 4a4007b394ae884e18e9d0319ea584e8b4a682d7bf8fa5b99c7eea9baf1e5ed6  lunix-20170920-1.src.rock
+sha256 9b74be104d59caa45bf3321ebe771f9cc7874209261a93f1cf971ceca44fbe03  lunix-rel-20170920/LICENSE
diff --git a/package/lua-lunix/lua-lunix.mk b/package/lua-lunix/lua-lunix.mk
new file mode 100644 (file)
index 0000000..28cb2dc
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lua-lunix
+#
+################################################################################
+
+LUA_LUNIX_VERSION_UPSTREAM = 20170920
+LUA_LUNIX_VERSION = $(LUA_LUNIX_VERSION_UPSTREAM)-1
+LUA_LUNIX_NAME_UPSTREAM = lunix
+LUA_LUNIX_SUBDIR = lunix-rel-$(LUA_LUNIX_VERSION_UPSTREAM)
+LUA_LUNIX_LICENSE = MIT
+LUA_LUNIX_LICENSE_FILES = $(LUA_LUNIX_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))
diff --git a/support/testing/tests/package/test_lua_lunix.py b/support/testing/tests/package/test_lua_lunix.py
new file mode 100644 (file)
index 0000000..ae0e3b2
--- /dev/null
@@ -0,0 +1,25 @@
+from tests.package.test_lua import TestLuaBase
+
+
+class TestLuaLunix(TestLuaBase):
+    config = TestLuaBase.config + \
+        """
+        BR2_PACKAGE_LUA=y
+        BR2_PACKAGE_LUA_LUNIX=y
+        """
+
+    def test_run(self):
+        self.login()
+        self.module_test("unix")
+
+
+class TestLuajitLunix(TestLuaBase):
+    config = TestLuaBase.config + \
+        """
+        BR2_PACKAGE_LUAJIT=y
+        BR2_PACKAGE_LUA_LUNIX=y
+        """
+
+    def test_run(self):
+        self.login()
+        self.module_test("unix")