opengl: libgles and libegl also provided by gpu-viv-bin-mx6q
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Aug 2013 08:54:19 +0000 (10:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Aug 2013 08:54:19 +0000 (10:54 +0200)
The gpu-viv-bin-mx6q package selects BR2_PACKAGE_HAS_OPENGL_EGL and
BR2_PACKAGE_HAS_OPENGL_ES, so when it is enabled, Buildroot believes
that OpenGL and EGL support is available.

However, both libgles.mk and libegl.mk do not add the dependency on
gpu-viv-bin-mx6q, so when pulling the libgles or libegl dependencies,
the build fails due to the absence of an OpenGL implementation. This
commit fixes that.

Fixes the build failure at
http://autobuild.buildroot.org/results/dbd/dbd938914883a9e205f967f7b4b4a8a7dc7be117/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/opengl/libegl/libegl.mk
package/opengl/libgles/libgles.mk

index 97a4b85b571624a4a5119b9a538452d198dd7a00..c194b027641903bd43e383817b29d4341b88a5e3 100644 (file)
@@ -18,6 +18,10 @@ ifeq ($(BR2_PACKAGE_SUNXI_MALI),y)
 LIBEGL_DEPENDENCIES += sunxi-mali
 endif
 
+ifeq ($(BR2_PACKAGE_GPU_VIV_BIN_MX6Q),y)
+LIBEGL_DEPENDENCIES += gpu-viv-bin-mx6q
+endif
+
 ifeq ($(LIBEGL_DEPENDENCIES),)
 define LIBEGL_CONFIGURE_CMDS
        echo "No libEGL implementation selected. Configuration error."
index 2945496492bf0975555ce3ff5857842cba543199..ec157ac506bdf2ddbe20d0c72f73a8307dbdb0f3 100644 (file)
@@ -18,6 +18,10 @@ ifeq ($(BR2_PACKAGE_SUNXI_MALI),y)
 LIBGLES_DEPENDENCIES += sunxi-mali
 endif
 
+ifeq ($(BR2_PACKAGE_GPU_VIV_BIN_MX6Q),y)
+LIBGLES_DEPENDENCIES += gpu-viv-bin-mx6q
+endif
+
 ifeq ($(LIBGLES_DEPENDENCIES),)
 define LIBGLES_CONFIGURE_CMDS
        echo "No libGLES implementation selected. Configuration error."