Makefile: unexport 'PLATFORM' and 'OS' environment variables
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 5 Feb 2019 11:03:42 +0000 (12:03 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Feb 2019 14:22:30 +0000 (15:22 +0100)
Some package builds may fail when environment variables are present with the
same names as make variables in a package. This is a bigger problem for
environment variables with generic names, like 'PLATFORM' and 'OS'.

'PLATFORM' is for example a problem for host-acl.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 355a404e04dc6cb2688e9c1697bf794a848292f8..50a9f623b2edeb4196f92886126323fffa91530b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -419,6 +419,8 @@ unexport TERMINFO
 unexport MACHINE
 unexport O
 unexport GCC_COLORS
+unexport PLATFORM
+unexport OS
 
 GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)