Some 'find' commands get a little picky.
author"Steven J. Hill" <sjhill@realitydiluted.com>
Thu, 19 Apr 2007 02:04:15 +0000 (02:04 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Thu, 19 Apr 2007 02:04:15 +0000 (02:04 -0000)
toolchain/external-toolchain/ext-tool.mk

index ab4cbef6c04ce99841e35610af2ed0395f836735..b643b92fc13b7d180fc7df0c79fc3e570b4c381b 100644 (file)
@@ -18,7 +18,7 @@ copy_toolchain_lib_root =                                                                     \
        fi;                                                                                     \
                                                                                                \
        LIB="$(strip $1)";                                                                      \
-       for FILE in `find $${LIB_DIR} -type l -name "$${LIB}*" -maxdepth 1`; do                 \
+       for FILE in `find $${LIB_DIR} -maxdepth 1 -type l -name "$${LIB}*"`; do                 \
                LIB=`basename $${FILE}`;                                                        \
                while test \! -z "$${LIB}"; do                                                  \
                        echo "copy_toolchain_lib_root lib=$${LIB} dst=$${DST}";                 \