gdb: unbreak host-gdb with python support if python3 is enabled
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 08:38:10 +0000 (09:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 08:38:10 +0000 (09:38 +0100)
Fixes http://autobuild.buildroot.net/results/ef4/ef487b495e57f098af0fe9508d430b56b0750339/

Explicitly pass the path to host-python to ensure it gets used.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index 8d0f76dcc6423f60a705592977a54b3ed09d807a..dbec760f192bfb6bf083ee6c35d016fbf25f34ca 100644 (file)
@@ -146,7 +146,7 @@ else
 endif
 
 ifeq ($(BR2_PACKAGE_HOST_GDB_PYTHON),y)
-       HOST_GDB_CONF_OPTS += --with-python
+       HOST_GDB_CONF_OPTS += --with-python=$(HOST_DIR)/usr/bin/python2
        HOST_GDB_DEPENDENCIES += host-python
 else
        HOST_GDB_CONF_OPTS += --without-python