package/heirloom-mailx: fix link issue with getopt
authorRomain Naour <romain.naour@openwide.fr>
Sat, 16 May 2015 21:22:22 +0000 (23:22 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 16 May 2015 21:31:07 +0000 (23:31 +0200)
With NIOS2 toolchain, heirloom-mailx fail to build
due to missing -fPIC when linking with its own getopt.

Since static build for heirloom-mailx is disabled,
always pass -fPIC in CFLAGS.

Fixes:
http://autobuild.buildroot.net/results/333/33346f4555ed403bab7b739dd5d47814efa8eb4c

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/heirloom-mailx/heirloom-mailx.mk

index 73434796b7395d386b7b315bbfb0defb5d93a8f0..044cd8cf3ac304ad011ca852eb6b280bcb1542bf 100644 (file)
@@ -18,8 +18,11 @@ define HEIRLOOM_MAILX_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(SHELL) ./makeconfig)
 endef
 
+# -fPIC is needed to build with NIOS2 toolchains.
 define HEIRLOOM_MAILX_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) \
+               CFLAGS="$(TARGET_CFLAGS) -fPIC" \
+               -C $(@D)
 endef
 
 define HEIRLOOM_MAILX_INSTALL_TARGET_CMDS