libgtk2: point to the proper cups-config
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 26 Mar 2016 19:17:34 +0000 (16:17 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Mar 2016 20:35:18 +0000 (21:35 +0100)
Otherwise it can pick up the distro cups-config if it's present, leading
to improper library usage/linkage. Fixes:
http://autobuild.buildroot.net/results/bf4/bf493977817a750427aae82e71a5257187bd7344/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libgtk2/libgtk2.mk

index 971e33cc186e95ad97684c5cc7aac252b23b4c14..94fa97f20439f1a4ea533e943ee1cc44a6517163 100644 (file)
@@ -85,6 +85,7 @@ LIBGTK2_CONF_OPTS += --without-libtiff
 endif
 
 ifeq ($(BR2_PACKAGE_CUPS),y)
+LIBGTK2_CONF_OPTS += CUPS_CONFIG="$(STAGING_DIR)/usr/bin/cups-config"
 LIBGTK2_DEPENDENCIES += cups
 else
 LIBGTK2_CONF_OPTS += --disable-cups