collectd: add hugepages plugin support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 Dec 2016 01:59:17 +0000 (22:59 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:41:33 +0000 (22:41 +0100)
Add explicit support for the new hugepages dependency-less plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index b17abe830c2909d2a8bf0ea735d79136de752636..7cd6397e68fc7fb6e3c7bbfeb83c5ed677f62ab3 100644 (file)
@@ -237,6 +237,11 @@ config BR2_PACKAGE_COLLECTD_FSCACHE
          Collects information about the file-system based caching
          infrastructure for network file-systems and other slow media.
 
+config BR2_PACKAGE_COLLECTD_HUGEPAGES
+       bool "hugepages"
+       help
+         Reports the number of used and free hugepages on Linux.
+
 config BR2_PACKAGE_COLLECTD_INTERFACE
        bool "interface"
        help
index 2b57e51d9287ae9093355d6a7ee27285e93709f9..392c76f7dbaa9ef109891630ca673e50a1f9e304 100644 (file)
@@ -59,6 +59,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_FSCACHE),--enable-fscache,--disable-fscache) \
        $(if $(BR2_PACKAGE_COLLECTD_GRAPHITE),--enable-write_graphite,--disable-write_graphite) \
        $(if $(BR2_PACKAGE_COLLECTD_HASHED),--enable-match_hashed,--disable-match_hashed) \
+       $(if $(BR2_PACKAGE_COLLECTD_HUGEPAGES),--enable-hugepages,--disable-hugepages) \
        $(if $(BR2_PACKAGE_COLLECTD_INTERFACE),--enable-interface,--disable-interface) \
        $(if $(BR2_PACKAGE_COLLECTD_IPC),--enable-ipc,--disable-ipc) \
        $(if $(BR2_PACKAGE_COLLECTD_IPTABLES),--enable-iptables,--disable-iptables) \