package/gdb: add dependency on host-textinfo
authorRomain Naour <romain.naour@gmail.com>
Tue, 5 Jul 2016 16:02:29 +0000 (18:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Jul 2016 18:15:14 +0000 (20:15 +0200)
Starting with gdb 7.10, gdb wants to re-generate its documentation.
We were trying to avoid that by patching the Makefiles, but it wasn't
working in all situations. So, we simply add a dependency on
host-texinfo in all case.

Fixes:
http://autobuild.buildroot.net/results/f72/f72eac3e2f995e93f0e8f215e68ce4356a696dcb

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/gdb.mk

index 6d70955de0c6ec96610441dcd8fcbf503fcff2b8..1e23e5a36ca644d030ee74fbc310d7f5cfd0773f 100644 (file)
@@ -37,6 +37,13 @@ endif
 # also need ncurses.
 HOST_GDB_DEPENDENCIES = host-expat host-ncurses
 
+# Starting with gdb 7.10, gdb wants to re-generate its documentation.
+# We were trying to avoid that by patching the Makefiles, but it wasn't
+# working in all situations. So, we simply add a dependency on
+# host-texinfo in all case.
+GDB_DEPENDENCIES += host-texinfo
+HOST_GDB_DEPENDENCIES += host-texinfo
+
 # Apply the Xtensa specific patches
 XTENSA_CORE_NAME = $(call qstrip, $(BR2_XTENSA_CORE_NAME))
 ifneq ($(XTENSA_CORE_NAME),)
@@ -49,8 +56,8 @@ HOST_GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 endif
 
 ifeq ($(GDB_FROM_GIT),y)
-GDB_DEPENDENCIES += host-texinfo host-flex host-bison
-HOST_GDB_DEPENDENCIES += host-texinfo host-flex host-bison
+GDB_DEPENDENCIES += host-flex host-bison
+HOST_GDB_DEPENDENCIES += host-flex host-bison
 endif
 
 # When gdb sources are fetched from the binutils-gdb repository, they