Add lpc3250loader to the host tools
authorAlexandre Belloni <alexandre.belloni@piout.net>
Tue, 7 Feb 2012 11:01:25 +0000 (12:01 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Mar 2012 14:39:17 +0000 (15:39 +0100)
[Peter: use install -D for installation]
Signed-off-by: Alexandre Belloni <alexandre.belloni@piout.net>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in.host
package/lpc3250loader/Config.in.host [new file with mode: 0644]
package/lpc3250loader/lpc3250loader.mk [new file with mode: 0644]

index 1f49e79a7e8a80f8509e1a191085618d0ac1e3b9..861b7367db2c21f3888203ffc7bd6045cecfcf35 100644 (file)
@@ -1,5 +1,6 @@
 menu "Host utilities"
 
+source "package/lpc3250loader/Config.in.host"
 source "package/openocd/Config.in.host"
 source "package/sam-ba/Config.in.host"
 source "package/uboot-tools/Config.in.host"
diff --git a/package/lpc3250loader/Config.in.host b/package/lpc3250loader/Config.in.host
new file mode 100644 (file)
index 0000000..750080b
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_HOST_LPC3250LOADER
+       bool "host lpc3250loader"
+       help
+         lpc3250loader is a tool to load/burn programs (in particular kickstart
+         and S1L) on an LPC3250 platform.
+
+         https://gitorious.org/lpc3250loader
diff --git a/package/lpc3250loader/lpc3250loader.mk b/package/lpc3250loader/lpc3250loader.mk
new file mode 100644 (file)
index 0000000..ed6485c
--- /dev/null
@@ -0,0 +1,9 @@
+HOST_LPC3250LOADER_SITE = git://gitorious.org/lpc3250loader/lpc3250loader.git
+HOST_LPC3250LOADER_VERSION = 1.0
+
+define HOST_LPC3250LOADER_INSTALL_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/LPC3250loader.py \
+               $(HOST_DIR)/usr/bin/LPC3250loader.py
+endef
+
+$(eval $(call GENTARGETS,host))