package/stella: bump version to 4.7.3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 29 May 2017 19:14:29 +0000 (21:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Jun 2017 21:02:45 +0000 (23:02 +0200)
Removed patch applied upstream:
https://github.com/stella-emu/stella/commit/be2f6f5b64266f4d68af6a2236bd4b59a7e6638d

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/stella/0003-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch [new file with mode: 0644]
package/stella/0003-configure-Add-CXXFLAGS-for-test-compilations.patch [deleted file]
package/stella/0004-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch [deleted file]
package/stella/stella.hash
package/stella/stella.mk

diff --git a/package/stella/0003-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch b/package/stella/0003-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch
new file mode 100644 (file)
index 0000000..76d12a2
--- /dev/null
@@ -0,0 +1,35 @@
+From 6946a491cae42b971aad3bc5d822e0e549eca8bd Mon Sep 17 00:00:00 2001
+From: Sergio Prado <sergio.prado@e-labworks.com>
+Date: Thu, 1 Dec 2016 15:20:33 -0200
+Subject: [PATCH] Use gnu++11 standard to prevent errors on PPC.
+
+PPC altivec vectorization triggers a bug when compiling with -std=c++11
+because "bool" is redefined in altivec.h.
+
+Acording to a bug report in GCC, "You need to use -std=g++11 or
+undefine bool after the include of altivec.h as context sensitive
+keywords is not part of the C++11 standard".
+
+So let's use gnu++11 standard.
+
+Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 6dd0129587b3..6ed50ea4c335 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,7 +51,7 @@ else
+ endif
+ CXXFLAGS+= -Wall -Wextra -Wno-unused-parameter -Wno-ignored-qualifiers
+ ifdef HAVE_GCC
+-  CXXFLAGS+= -Wno-multichar -Wunused -fno-rtti -Woverloaded-virtual -Wnon-virtual-dtor -std=c++11
++  CXXFLAGS+= -Wno-multichar -Wunused -fno-rtti -Woverloaded-virtual -Wnon-virtual-dtor -std=gnu++11
+ endif
+ ifdef PROFILE
+-- 
+1.9.1
+
diff --git a/package/stella/0003-configure-Add-CXXFLAGS-for-test-compilations.patch b/package/stella/0003-configure-Add-CXXFLAGS-for-test-compilations.patch
deleted file mode 100644 (file)
index c548d08..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From 28f0c20302e5c64712899848cae3d0a48a9dc952 Mon Sep 17 00:00:00 2001
-From: Vlad Zakharov <vzakhar@synopsys.com>
-Date: Wed, 10 Aug 2016 18:02:59 +0300
-Subject: [PATCH] configure: Add $CXXFLAGS for test compilations
-
-Why we are passing only linker flags when compiling test code?
-Loosing compiler flags leads to errors.
-
-Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com>
----
- configure | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/configure b/configure
-index 0d90a4f..618fe78 100755
---- a/configure
-+++ b/configure
-@@ -63,9 +63,9 @@ cc_check() {
-       echo >> "$TMPLOG"
-       cat "$TMPC" >> "$TMPLOG"
-       echo >> "$TMPLOG"
--      echo "$CXX $TMPC $LDFLAGS -o $TMPO$EXEEXT $@" >> "$TMPLOG"
-+      echo "$CXX $TMPC $CXXFLAGS $LDFLAGS -o $TMPO$EXEEXT $@" >> "$TMPLOG"
-       rm -f "$TMPO$EXEEXT"
--      ( $CXX "$TMPC" $LDFLAGS -o "$TMPO$EXEEXT" "$@" ) >> "$TMPLOG" 2>&1
-+      ( $CXX "$TMPC" $CXXFLAGS $LDFLAGS -o "$TMPO$EXEEXT" "$@" ) >> "$TMPLOG" 2>&1
-       TMP="$?"
-       echo >> "$TMPLOG"
-       return "$TMP"
-@@ -107,9 +107,9 @@ EOF
- if test -n "$_host"; then
-       # In cross-compiling mode, we cannot run the result
--      eval "$1 $LDFLAGS -o tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp 2> /dev/null" && rm -f tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp
-+      eval "$1 $CXXFLAGS $LDFLAGS -o tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp 2> /dev/null" && rm -f tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp
- else
--      eval "$1 $LDFLAGS -o tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp 2> /dev/null" && eval "./tmp_cxx_compiler 2> /dev/null" && rm -f tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp
-+      eval "$1 $CXXFLAGS $LDFLAGS -o tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp 2> /dev/null" && eval "./tmp_cxx_compiler 2> /dev/null" && rm -f tmp_cxx_compiler$EXEEXT tmp_cxx_compiler.cpp
- fi
- }
--- 
-2.5.5
-
diff --git a/package/stella/0004-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch b/package/stella/0004-Use-gnu-11-standard-to-prevent-errors-on-PPC.patch
deleted file mode 100644 (file)
index 76d12a2..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From 6946a491cae42b971aad3bc5d822e0e549eca8bd Mon Sep 17 00:00:00 2001
-From: Sergio Prado <sergio.prado@e-labworks.com>
-Date: Thu, 1 Dec 2016 15:20:33 -0200
-Subject: [PATCH] Use gnu++11 standard to prevent errors on PPC.
-
-PPC altivec vectorization triggers a bug when compiling with -std=c++11
-because "bool" is redefined in altivec.h.
-
-Acording to a bug report in GCC, "You need to use -std=g++11 or
-undefine bool after the include of altivec.h as context sensitive
-keywords is not part of the C++11 standard".
-
-So let's use gnu++11 standard.
-
-Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 6dd0129587b3..6ed50ea4c335 100644
---- a/Makefile
-+++ b/Makefile
-@@ -51,7 +51,7 @@ else
- endif
- CXXFLAGS+= -Wall -Wextra -Wno-unused-parameter -Wno-ignored-qualifiers
- ifdef HAVE_GCC
--  CXXFLAGS+= -Wno-multichar -Wunused -fno-rtti -Woverloaded-virtual -Wnon-virtual-dtor -std=c++11
-+  CXXFLAGS+= -Wno-multichar -Wunused -fno-rtti -Woverloaded-virtual -Wnon-virtual-dtor -std=gnu++11
- endif
- ifdef PROFILE
--- 
-1.9.1
-
index 71defd28d0f2eff3482bb16db06eedbda3600202..e6f146fd9345b58fa83bd6ca04307cd57ff15d30 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256 b2727a0e2d3b112d35dcb89b4bdc789e2c7f15e9d9c7054a69a2f67facd7416e  stella-4.7.2-src.tar.xz
+sha256 93a75d1b343b1e66b6dc526c0f9d8a0c3678d346033f7cdfe76dc93f14d956ad  stella-4.7.3-src.tar.xz
index fbf7809a171197ae1f6e574e73e8664e33da2a2c..e610a9bdfd6fa8b27f08d3678b59baa5050a076a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-STELLA_VERSION = 4.7.2
+STELLA_VERSION = 4.7.3
 STELLA_SOURCE = stella-$(STELLA_VERSION)-src.tar.xz
 STELLA_SITE = https://github.com/stella-emu/stella/releases/download/release-$(STELLA_VERSION)
 STELLA_LICENSE = GPL-2.0+