ext-toolchain: fix ct-ng as external rsync issues
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 13 Oct 2011 16:18:51 +0000 (13:18 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 2 Nov 2011 11:28:41 +0000 (12:28 +0100)
When using a CT-NG toolchain as external toolchain (not with the
integration) and said toolchain has u-w directories rsync fails.
So instruct rsync to chmod u+w directories in the target copy to avoid
the issue.

[Peter: notice that this is a workaround for a rsync 3.0.8 bug]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 5585f45fe3c5c50241aa447e6620f6c04ba60223..96919d4b139b81abb22fefb4c2d6ac7771f3f72b 100644 (file)
@@ -91,7 +91,7 @@ copy_toolchain_sysroot = \
        ARCH_SUBDIR="$(strip $3)"; \
        for i in etc lib sbin usr ; do \
                if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
-                       rsync -au --exclude 'usr/lib/locale' $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
+                       rsync -au --chmod=Du+w --exclude 'usr/lib/locale' $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
                fi ; \
        done ; \
        if [ `readlink -f $${SYSROOT_DIR}` != `readlink -f $${ARCH_SYSROOT_DIR}` ] ; then \