libcurl: add support for compiling with libssh2
authorRyan Barnett <rjbarnet@rockwellcollins.com>
Fri, 30 Aug 2013 14:09:45 +0000 (09:09 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 8 Sep 2013 19:53:11 +0000 (21:53 +0200)
Adding configuration options that if libssh2 is selected, compile libcurl
with --with-ssh config flag.

Signed-off-by: Ryan Barnett <rjbarnet@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libcurl/libcurl.mk

index 71f19f19c3855c8f07f0f16338c94638acd430a6..059f08a1192cdaef766f93fb1bd86f8a83cbe332 100644 (file)
@@ -47,6 +47,14 @@ LIBCURL_CONF_OPT += --without-ssl --without-gnutls \
        --without-polarssl --without-nss
 endif
 
+# Configure curl to support libssh2
+ifeq ($(BR2_PACKAGE_LIBSSH2),y)
+LIBCURL_DEPENDENCIES += libssh2
+LIBCURL_CONF_OPT += --with-libssh2
+else
+LIBCURL_CONF_OPT += --without-libssh2
+endif
+
 define LIBCURL_FIX_DOT_PC
        printf 'Requires: openssl\n' >>$(@D)/libcurl.pc.in
 endef