Makefile: don't include .config from TOPDIR
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Jun 2008 13:47:37 +0000 (13:47 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Jun 2008 13:47:37 +0000 (13:47 -0000)
If we ever want to support building out of tree, having the .config in the
tree is probably not what we want.

Makefile

index 73d92088afb64ff1afd6553c89fd16150da493a3..fcf69ce25506933e0b73ad2ca7469de69b3bccc8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ endif
 ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 ifeq ($(BOARD),)
 # if "make BOARD=xyz" command
--include $(TOPDIR).config
+-include .config
 else
 # if "make" command
 -include $(BR2_LOCAL)/$(BOARD)/$(BOARD).config