Makefile: Force make to run serially in the top-level Makefile
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Tue, 28 Sep 2010 21:50:58 +0000 (23:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 Sep 2010 12:37:01 +0000 (14:37 +0200)
The top-level Makefile can be executed in parallel, as it causes problems.
We can force make to be not parallel.

It's been reported many times, and recent discussions on IRC with kos_tom,
and user nick-named knee, led to this patch.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index aab346e9425e5a5b8ee97b5941922ea046d48bbb..9c2e6af1a9a598fc6f508b08ab267f94c9e99b3b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,9 @@
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
 #
 
+# This top-level Makefile can *not* be executed in parallel
+.NOTPARALLEL:
+
 #--------------------------------------------------------------
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...