gettext: remove useless ABOUT-NLS file
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 28 Jun 2014 21:52:23 +0000 (23:52 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Jul 2014 12:58:26 +0000 (14:58 +0200)
For some reason, gettext installs on the target a documentation file
named ABOUT-NLS in /usr/share/gettext, that is clearly not needed for
the proper execution of programs. This commit adds a post-install hook
in gettext.mk to get rid of this file.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gettext/gettext.mk

index 948ab9de53e7897e6614270c55908d3906efd3b4..cc461f7e042fdacfc3acc7fa1ea5382e29fbdd67 100644 (file)
@@ -50,6 +50,13 @@ endef
 GETTEXT_POST_PATCH_HOOKS += HOST_GETTEXT_DISABLE_UNNEEDED
 HOST_GETTEXT_POST_PATCH_HOOKS += HOST_GETTEXT_DISABLE_UNNEEDED
 
+define GETTEXT_REMOVE_UNNEEDED
+       $(RM) -rf $(TARGET_DIR)/usr/share/gettext/ABOUT-NLS
+       rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share/gettext
+endef
+
+GETTEXT_POST_INSTALL_TARGET_HOOKS += GETTEXT_REMOVE_UNNEEDED
+
 # Force build with NLS support, otherwise libintl is not built
 # This is needed because some packages (eg. libglib2) requires
 # locales, but do not properly depend on BR2_ENABLE_LOCALE, and