package/pkg-waf.mk: allow for override of <pkg>_WAF directive
authorDavid GOUARIN <dgouarin@gmail.com>
Tue, 13 Oct 2020 19:49:45 +0000 (21:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 14 Oct 2020 19:14:27 +0000 (21:14 +0200)
Some packages have their own waf copy, but not located at the
top-level directory. In order to support those packages, we allow
packages to override the default <pkg>_WAF location.

Signed-off-by: David GOUARIN <dgouarin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-waf.mk

index 35e56d3c138a9bc4cf4581532eabaaa38d3eedd9..038d89454e6d9a9fcb3f67728c9c9487a8a03dcd 100644 (file)
@@ -46,7 +46,7 @@ ifeq ($$($(2)_NEEDS_EXTERNAL_WAF),YES)
 $(2)_DEPENDENCIES += host-waf
 $(2)_WAF = $$(HOST_DIR)/bin/waf
 else
-$(2)_WAF = ./waf
+$(2)_WAF ?= ./waf
 endif
 
 $(2)_BUILD_OPTS                                ?=