package/python3-decorator: new package
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 23 Jul 2020 19:45:59 +0000 (21:45 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 27 Jul 2020 14:29:18 +0000 (16:29 +0200)
The host-python-networkx package needs to be built for the
host-python3, even when the target Python is not necessarily Python
3.x. Since it depends on host-python-decorator, we need a Python 3
variant of it, which this patch introduces.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-decorator/python-decorator.mk
package/python3-decorator/python3-decorator.hash [new symlink]
package/python3-decorator/python3-decorator.mk [new file with mode: 0644]

index 8df1dd70c9d999f71e0cb44bcbec1a9f00f233a2..e555f01ba15604b598d12f6292e16fad02477822 100644 (file)
@@ -4,6 +4,7 @@
 #
 ################################################################################
 
+# Please keep in sync with package/python3-decorator/python3-decorator.mk
 PYTHON_DECORATOR_VERSION = 4.4.1
 PYTHON_DECORATOR_SITE = https://files.pythonhosted.org/packages/dc/c3/9d378af09f5737cfd524b844cd2fbb0d2263a35c11d712043daab290144d
 PYTHON_DECORATOR_SOURCE = decorator-$(PYTHON_DECORATOR_VERSION).tar.gz
diff --git a/package/python3-decorator/python3-decorator.hash b/package/python3-decorator/python3-decorator.hash
new file mode 120000 (symlink)
index 0000000..f515d31
--- /dev/null
@@ -0,0 +1 @@
+../python-decorator/python-decorator.hash
\ No newline at end of file
diff --git a/package/python3-decorator/python3-decorator.mk b/package/python3-decorator/python3-decorator.mk
new file mode 100644 (file)
index 0000000..d809bb5
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# python3-decorator
+#
+################################################################################
+
+# Please keep in sync with package/python-decorator/python-decorator.mk
+PYTHON3_DECORATOR_VERSION = 4.4.1
+PYTHON3_DECORATOR_SITE = https://files.pythonhosted.org/packages/dc/c3/9d378af09f5737cfd524b844cd2fbb0d2263a35c11d712043daab290144d
+PYTHON3_DECORATOR_SOURCE = decorator-$(PYTHON_DECORATOR_VERSION).tar.gz
+PYTHON3_DECORATOR_LICENSE = BSD-2-Clause
+PYTHON3_DECORATOR_LICENSE_FILES = LICENSE.txt
+PYTHON3_DECORATOR_SETUP_TYPE = setuptools
+HOST_PYTHON3_DECORATOR_NEEDS_HOST_PYTHON = python3
+
+$(eval $(host-python-package))