qt5webkit: correct download URL and hash for 5.6 variant
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 16 Nov 2017 14:23:04 +0000 (15:23 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 17 Nov 2017 09:31:55 +0000 (10:31 +0100)
Commit 06a4975d4bd03 (qt5: bump LTS version to 5.6.3) added an empty hash
for the 5.6.3 variant of qt5webkit, causing failures.

It also forgot to adjust the download URL as the qt5webkit tarballs are no
longer available under official_releases/ like the other submodules, but only
under community_releases/.

Fix both issues.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5webkit/qt5webkit.hash
package/qt5/qt5webkit/qt5webkit.mk

index 1a5e72664f23dec93ebb96cb568785faa855d422..aa3a71c8d04228ebdf1ab9c49c01e1a5d4c4ba0c 100644 (file)
@@ -1,5 +1,5 @@
-# Hash from: http://download.qt.io/snapshots/qt/5.6/5.6.3/latest_src/submodules/qtwebkit-opensource-src-5.6.3.tar.xz.mirrorlist
-sha256  qtwebkit-opensource-src-5.6.3.tar.xz
+# Hash from: http://download.qt.io/community_releases/5.6/5.6.3/qtwebkit-opensource-src-5.6.3.tar.xz.mirrorlist
+sha256  098c6bb25798fbf1b619b540621287787064efc9b586d76ac0ce7e39b87a3896  qtwebkit-opensource-src-5.6.3.tar.xz
 
 # hash from: http://download.qt.io/official_releases/qt/5.9/5.9.1/submodules/qtwebkit-opensource-src-5.9.1.tar.xz.mirrorlist
 sha256  28a560becd800a4229bfac317c2e5407cd3cc95308bc4c3ca90dba2577b052cf  qtwebkit-opensource-src-5.9.1.tar.xz
index 6e982e6bc7348663d09c2fdb8d932de7ea2f9ceb..592eae908df5606ddc4a833ee43aa7b63412ea65 100644 (file)
@@ -10,7 +10,7 @@ QT5WEBKIT_VERSION = 5.9.1
 QT5WEBKIT_SITE = http://download.qt.io/official_releases/qt/5.9/5.9.1/submodules
 else
 QT5WEBKIT_VERSION = $(QT5_VERSION)
-QT5WEBKIT_SITE = $(QT5_SITE)
+QT5WEBKIT_SITE = http://download.qt.io/community_releases/5.6/$(QT5_VERSION)/submodules
 endif
 
 QT5WEBKIT_SOURCE = qtwebkit-opensource-src-$(QT5WEBKIT_VERSION).tar.xz