linux/perf: honour the number of parallel jobs
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 11 Mar 2016 18:19:55 +0000 (19:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Mar 2016 13:37:32 +0000 (14:37 +0100)
perf does not honour the -j flags we pass to make; it yet again tries to
reinvent the wheel and by default uses the number of CPUs as the number
of parallel jobs.

Fortunately, in their infinite wisdom, the insane developpers of the
perf buildsystem were kind enough to provide us with a variable we can
set to specify the number of parallel jobs.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux-tool-perf.mk

index f9b295fb13edd36f454a10c98cd47cfe4033c457..a5fbf2197cb8b66128937cb40096e8feae30f3b2 100644 (file)
@@ -16,6 +16,7 @@ endif
 
 PERF_MAKE_FLAGS = \
        $(LINUX_MAKE_FLAGS) \
+       JOBS=$(PARALLEL_JOBS) \
        ARCH=$(PERF_ARCH) \
        NO_LIBAUDIT=1 \
        NO_NEWT=1 \