libvncserver: add config option for tightpng encoding support
authorFloris Bos <bos@je-eigen-domein.nl>
Sat, 27 Dec 2014 19:12:54 +0000 (20:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 20:30:05 +0000 (21:30 +0100)
TightPNG encoding speeds up HTML5 based VNC clients like noVNC.
libvncserver enables this encoding if both libpng and jpeg libraries
are available.

[Thomas: rewrap Config.in help text.]

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libvncserver/Config.in
package/libvncserver/libvncserver.mk

index 07b77f519e56d01789ab7dda80957957f54d4502..28fbaa583362795b5ecdda853773e6e634e53a66 100644 (file)
@@ -5,3 +5,17 @@ config BR2_PACKAGE_LIBVNCSERVER
          libvncserver is a VNC server/client library.
 
          http://libvncserver.sourceforge.net/
+
+if BR2_PACKAGE_LIBVNCSERVER
+
+config BR2_PACKAGE_LIBVNCSERVER_TIGHTPNG
+       bool "TightPNG encoding support"
+       select BR2_PACKAGE_JPEG
+       select BR2_PACKAGE_LIBPNG
+       help
+         TightPNG encoding speeds up HTML5 based VNC clients like
+         noVNC.
+
+         http://wiki.qemu.org/VNC_Tight_PNG
+
+endif
index a8389b4203d9440558dabd18eff59c3f3dc9acde..ed6b64d95b5e5f2de32b3f9fd880bd47ab677da3 100644 (file)
@@ -58,6 +58,12 @@ else
 LIBVNCSERVER_CONF_OPTS += --without-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+LIBVNCSERVER_DEPENDENCIES += libpng
+else
+LIBVNCSERVER_CONF_OPTS += --without-png
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LIBVNCSERVER_DEPENDENCIES += zlib
 else