gawk: install /usr/bin/awk as a relative symlink
authorCarlos Santos <casantos@datacom.com.br>
Wed, 25 Jul 2018 11:18:10 +0000 (08:18 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Jul 2018 16:15:30 +0000 (18:15 +0200)
Fixes:
  http://autobuild.buildroot.net/results/bf3937882023df7ed319dc76f1af10f79785112f/

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gawk/gawk.mk

index 1315abb9ee5453c921d2f2e07b6c7ab363959a37..7c93aefed62b0b3913a7741597443a4132010873 100644 (file)
@@ -34,7 +34,7 @@ endif
 HOST_GAWK_CONF_OPTS = --without-readline --without-mpfr
 
 define GAWK_CREATE_SYMLINK
-       ln -sf /usr/bin/gawk $(TARGET_DIR)/usr/bin/awk
+       ln -sf gawk $(TARGET_DIR)/usr/bin/awk
 endef
 
 GAWK_POST_INSTALL_TARGET_HOOKS += GAWK_CREATE_SYMLINK